Загрузка из EXCEL в 1С на платформе 8.3.6/8.3.7/8.3.8/8.3.9/8.3.10 (с картинками)

Публикация № 341855

Разработка - Практика программирования

MS Microsoft EXCEL Импорт Загрузка ТабличныйДокумент ТаблицаЗначений Картинка Изображение OpenOffice LibreOffice 8.3.6 8.3.7 8.3.8 8.3.9 8.3.10

Импорт содержимого из файлов в форматах XLS (Microsoft Excel 97), Microsoft Office OpenXML (Microsoft Excel 2007- 2010) и ODS (OpenDocument) в таблицу значений.

При написании публикации использовалась версия платформы 8.3.6.1760.
Модифицирована на версии платформы 8.3.10.2168.

Заметки из Зазеркалья: http://v8.1c.ru/o7/


Одним из полезных нововведений на платформе 8.3.6 стала возможность возможность импорта содержимого из файлов в форматах XLS (Microsoft Excel 97), Microsoft Office OpenXML (Microsoft Excel 2007- 2010) и ODS (OpenDocument) в табличный документ.
На платформе 8.3.10 появилась возможность считывания данных с отдельных листов книги EXCEL.
Данная возможность доступна как в интерактивном режиме, так и из встроенного языка.
Реализована поддержка вставки из буфера обмена областей, скопированных из Microsoft Excel и OpenOffice Calc.
Реализация импорта из EXCEL на встроенном языке стала возможна в результате нововведений в функционал объекта "ТабличныйДокумент":
Для метода "Прочитать" объекта "ТабличныйДокумент" реализован параметр "СпособЧтенияЗначений" (Новое системное перечисление "СпособЧтенияЗначенийТабличногоДокумента").

В данной публикации приводится пример реализации функционала импорта из файлов EXCEL (xlsx, xls, ods) в таблицу значений в режиме 1С:Предприятие на платформе 8.3.6.


Методы загрузки из внешнего источника:
- Метод "MS ADO" (Чтение файлов xls, xlsx, xlsb средствами Microsoft ADO): //sib.vc/public/163640/
- Метод "MS EXCEL" (Чтение файлов xls, xlsx, xlsb с картинками средствами Microsoft Office): //sib.vc/public/163641/
- Метод "LO CALC" (Чтение файлов xls, xlsx, xlsb, ods, sxc с картинками средствами LibreOffice): //sib.vc/public/163642/
- Метод "NativeXLSX" (Чтение файлов xlsx с картинками средствами 1С. ПостроительDOM): //sib.vc/public/300092/
- Метод "NativeXLSX". Предыдущий вариант (Чтение файлов xlsx средствами 1С. ЧтениеXML):
//sib.vc/public/225624/
- Метод "Excel1C" (Загрузка на платформе 8.3.6 с картинками. Чтение файлов xls, xlsx, ods): //sib.vc/public/341855/
- Список листов файла: //sib.vc/public/163724/


Данный функционал включен в обработку:
Импорт из EXCEL и др.источников (xls,xlsx,ods,sxc,dbf,mxl,csv,sql) в 1С: //sib.vc/public/120961/


О файле EXCEL:
В общем случае файл EXCEL содержит несколько листов с данными.
Метод табличного документа "Прочитать" читает все листы в 1 (один) табличный документ на платформах 8.3.6-8.3.9, а на платформе 8.3.10 можно считать отдельные листы файла EXCEL.
Поэтому для использования данного функционала на версиях платформы 8.3.6-8.3.9 необходимо использовать файлы EXCEL, содержащие 1 (один) лист с данными, для платформы 8.3.10, такого ограничения нет.
О листе файла EXCEL:
Содержимое на листе должно быть разнесено по соответствующим колонкам по назначению.
В качестве примера содержимого листа может служить обычный прайс.
Рекомендутся ячейки таблицы на листе файла оформлять рамкой  "Все границы".
Колонки результирующей таблицы значений формируются по количеству, определяемому свойством "ШиринаТаблицы" табличного документа.
В последствии для удобства пустые колонки удаляются из результирующей таблицы значений.
О типах значений файла EXCEL:
Числа - как "число", даты - как "дата", Стоки - как "строка", Булево - как "строка" вида "ИСТИНА" ("TRUE") или "ЛОЖЬ" ("FALSE").
В результирующую таблицу значений записываются типизованные значения.
О картинках файла EXCEL:
В исходном файле EXCEL это могут быть как ссылки на файлы, разделенные между собой символом "Перевод строки" в пределах одной ячейки, так и собственно картинки.
Картинки должны находиться в пределах ячейки. В одной ячейке может быть несколько картинок.
В результирующую таблицу значений записываются ссылки на файлы картинок.
Каждая ячейка колонки может, в общем случае, содержать несколько ссылок на файлы, разделенные между собой символом "Перевод строки".

Перем ВерсияПриложенияБезНомераСборки;

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Перем СистемнаяИнформация, СписокЛистов;
	
	СистемнаяИнформация = Новый СистемнаяИнформация;
	ВерсияПриложенияБезНомераСборки = ВерсияБезНомераСборки(СистемнаяИнформация.ВерсияПриложения);
	
	// Чтение в реквизит обработки, который может быть выведен на форму обработки.
	// Объект.ТабличныйДокумент.Прочитать(ИмяФайла, СпособЧтенияЗначенийТабличногоДокумента.Значение);
	
	// Запись табличного документа в файл на диске.
	// Для работы с табличным документом предусмотрена утилита 1С http://v8.1c.ru/metod/fileworkshop.htm
	// Объект.ТабличныйДокумент.Записать("D:\Товар1Лист.MXL", ТипФайлаТабличногоДокумента.MXL); 
	
	// Примеры вызова:
	Если ВерсияПриложенияМеньше8310() Тогда
		// Платформа 8.3.9 и более ранние (Файл EXCEL как 1 лист).
		ИмяФайла = "D:\1_LIST.xlsx";
		ТЗ = ЗагрузитьМетодом_EXCEL1C(ИмяФайла, "");              			// Считать весь файл.
		ТЗ = ЗагрузитьМетодом_EXCEL1C(ИмяФайла, "", 1, 3, 4);				// Считать с 3-ой до 4-ой строки всего файла.
	Иначе
		// Платформа 8.3.10 (Облать = Лист данных).
		ИмяФайла = "D:\N_LIST.xlsx";
		СписокЛистов = ПолучитьСписокЛистов_EXCEL1C(ИмяФайла);
		ТЗ = ЗагрузитьМетодом_EXCEL1C(ИмяФайла, СписокЛистов[0].Значение);	// Считать 1-ый лист из списка по алфавиту.
		ТЗ = ЗагрузитьМетодом_EXCEL1C(ИмяФайла, СписокЛистов[1].Значение);	// Считать 2-ой лист из списка по алфавиту.
		ТЗ = ЗагрузитьМетодом_EXCEL1C(ИмяФайла, СписокЛистов[1].Значение, 1, 3, 4);	// Считать с 3-ой до 4-ой строки 2-го листа из списка по алфавиту.
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Функция ПолучитьСписокЛистов_EXCEL1C(Знач ФайлEXCEL)
	Перем ТабличныйДокумент, ОбластьТД;
	Перем СписокЛистов;

	СписокЛистов = Новый СписокЗначений;
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	Попытка
		// Выполняется долго на больших файлах.
		ТабличныйДокумент.Прочитать(ФайлEXCEL);
	Исключение
		Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
		Возврат Новый СписокЗначений;
	КонецПопытки;
	
	Для Каждого ОбластьТД ИЗ ТабличныйДокумент.Области Цикл
		СписокЛистов.Добавить(ОбластьТД.Имя);
	КонецЦикла;
	
	Возврат СписокЛистов;
	
КонецФункции

// Метод "EXCEL1C" для файлов EXCEL с расширениями: xlsx, xls, ods.
//
// Параметры:
//		ФайлEXCEL - Полное имя файла (путь к файлу с именем файла и расширением).
//      ИмяЛиста - Имя листа файла (платформа 8.3.10).
//		СтрокаЗаголовка (по умолчанию = 1) - Номер строки файла типа MXL, в которой расположены заголовки колонок.
//		Не используется. 
//		В обработке 1-я строка анализируется для сопоставления колонок файла с реквизитами объектов 1С.
//		НачСтрока (по-умолчанию = 0) - Номер начальной строки, начиная с которой считываются данные из файла.
//		КонСтрока (по-умолчанию = 0) - Номер конечной строки, которой заканчиваются считываемые данные из файла.
//		Если НачСтрока=0 и КонСтрока=0, то считывается вся таблица, находящаяся в файле.
//		КолвоСтрокФайла - Количество строк в файле. Возвращается в вызвавшую процедуру.
//
// Возвращаемые значения:
//         ТаблицаРезультат - Результат считывания данных из файла.
//
&НаСервере
Функция ЗагрузитьМетодом_EXCEL1C(Знач ФайлEXCEL, Знач ИмяЛиста = "", Знач СтрокаЗаголовка = 1, НачСтрока = 0, КонСтрока = 0, КолвоСтрокФайла = 0)
	Перем ТабличныйДокумент, ОбластьФайла, КолВоКолонокФайла, ИмяКолонки, Область, ТекущаяОбласть, нСтрока, нКолонка, НоваяСтрокаТФ, ЗначениеЯчейки;
	Перем ТаблицаРезультат;
	
	ТабличныйДокумент = Новый ТабличныйДокумент;
	Попытка
		// Выполняется долго на больших файлах.
		ТабличныйДокумент.Прочитать(ФайлEXCEL, СпособЧтенияЗначенийТабличногоДокумента.Значение);    // СпособЧтенияЗначенийТабличногоДокумента - новый параметр платформы 8.3.6. Второе значение "Текст".
	Исключение
		Сообщить(ОписаниеОшибки(), СтатусСообщения.Внимание);
		Возврат Новый ТаблицаЗначений;
	КонецПопытки;
	
	ОбластьФайла = ТабличныйДокумент;
	Если ВерсияПриложенияМеньше8310() Тогда
		// Платформа 8.3.9 и более ранние (Файл EXCEL как 1 лист).
		КолвоСтрокФайла = ОбластьФайла.ВысотаТаблицы;
		КолВоКолонокФайла = ОбластьФайла.ШиринаТаблицы;
	Иначе
		// Платформа 8.3.10 (Облать = Лист данных).
		ОбластьФайла = ТабличныйДокумент.ПолучитьОбласть(ИмяЛиста);
		КолВоСтрокФайла = ОбластьФайла.ПолучитьРазмерОбластиДанныхПоВертикали();
		КолВоКолонокФайла = ОбластьФайла.ПолучитьРазмерОбластиДанныхПоГоризонтали();
	КонецЕсли;
	
	// Проверка заполненности листа.
	Если КолвоСтрокФайла = 0 Тогда
		// Завершение работы.
		// Закрытие Объектов.
		ТабличныйДокумент = Неопределено;
		Возврат Новый ТаблицаЗначений;    // В случае ошибки возвращаем пустую таблицу значений.
	КонецЕсли;
	
	// Создание результирующей таблицы, в которую будут записываться считанные из файла данные.
	ТаблицаРезультат = Новый ТаблицаЗначений;
	
	// Формирование колонок результирующей таблицы.
	
	// "НомерСтроки" - для наглядности и удобства.
	// В зависимости от разрабатываемой обработки.
	// "Сопоставлено" - может быть другим.
	// Здесь же могут быть добавлены другие колонки, не формируемые из содержимого файла.
	ТаблицаРезультат.Колонки.Добавить("НомерСтроки", Новый ОписаниеТипов("Число"), "№", 4);
	ТаблицаРезультат.Колонки.Добавить("Сопоставлено", Новый ОписаниеТипов("Булево"), "Сопоставлено", 1);
	
	Для ит = 1 ПО КолВоКолонокФайла Цикл
		нКолонка = СтрЗаменить(ит, Символы.НПП, "");
		ИмяКолонки = "N" + нКолонка;
		ТаблицаРезультат.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	
	// 1-я строка. Заголовки.
	НоваяСтрокаТФ = ТаблицаРезультат.Добавить();
	НоваяСтрокаТФ.НомерСтроки = 1;
	Для ит=1 ПО КолВоКолонокФайла Цикл
		нКолонка = СтрЗаменить(ит, Символы.НПП, "");
		ИмяКолонки = "N" + нКолонка;
		НоваяСтрокаТФ[ИмяКолонки] = ОбластьФайла.ПолучитьОбласть("R1" + "C"+нКолонка).ТекущаяОбласть.Текст;
		
		// Используется при формировании таблицы на форме обработки.
		ШиринаКолонки = ТаблицаРезультат.Колонки[ИмяКолонки].Ширина;
		ДлинаСтроки    = СтрДлина(СокрЛП(НоваяСтрокаТФ[ИмяКолонки]));
		ТаблицаРезультат.Колонки[ИмяКолонки].Ширина = ?(ШиринаКолонки < ДлинаСтроки, ДлинаСтроки, ШиринаКолонки);
	КонецЦикла;
	
	НачСтрока = ?(НачСтрока = 0, 2, НачСтрока);
	КонСтрока = ?(КонСтрока = 0, КолвоСтрокФайла, КонСтрока);
	
	Для нСтрокаТФ = НачСтрока ПО КонСтрока Цикл
		НоваяСтрокаТФ = ТаблицаРезультат.Добавить();
		НоваяСтрокаТФ[0] = нСтрокаТФ;
		нСтрока = СтрЗаменить(нСтрокаТФ, Символы.НПП, "");
		Для нКолонкаТФ = 1 ПО КолВоКолонокФайла Цикл
			нКолонка = СтрЗаменить(нКолонкаТФ, Символы.НПП, "");
			Область = ОбластьФайла.ПолучитьОбласть("R"+нСтрока+"C"+нКолонка);
			ТекущаяОбласть = Область.ТекущаяОбласть;
			Попытка
				ЗначениеЯчейки = ТекущаяОбласть.Значение;        // Число, Дата.
			Исключение
				ЗначениеЯчейки = СокрЛП(ТекущаяОбласть.Текст);    // Строка, Булево. (Булево как строка "ИСТИНА"/"ЛОЖЬ")
				Если ЗначениеЗаполнено(ЗначениеЯчейки) Тогда
					ЗначениеЯчейки = ПреобразоватьПростоеЗначениеИзСтрокиВТипизованноеЗначение1С(ЗначениеЯчейки);
					Если ТипЗнч(ЗначениеЯчейки) = Тип("Строка") Тогда
						ЗначениеЯчейки = СокрЛП(ЗначениеЯчейки);
					КонецЕсли;
				Иначе
					ЗначениеЯчейки = Неопределено;
					Если Область.Рисунки.Количество() > 0 Тогда    // Изображение.
						ЗначениеЯчейки = ПолучитьЗначениеЯчейкиОбластиТабличногоДокументаСКартинками(Область, нСтрока, нКолонка, "УИД");
					КонецЕсли;
				КонецЕсли;
			КонецПопытки;
			
			ИмяКолонки = "N" + нКолонка;
			НоваяСтрокаТФ[ИмяКолонки] = ЗначениеЯчейки;
			
			// Используется при формировании таблицы на форме обработки.
			ШиринаКолонки = ТаблицаРезультат.Колонки[ИмяКолонки].Ширина;
			ДлинаСтроки    = СтрДлина(СокрЛП(НоваяСтрокаТФ[ИмяКолонки]));
			ТаблицаРезультат.Колонки[ИмяКолонки].Ширина = ?(ШиринаКолонки < ДлинаСтроки, ДлинаСтроки, ШиринаКолонки);
		КонецЦикла;
	КонецЦикла;
	
	// Юзабилити. Удалить пустые колонки.
	УдалитьКолонкиСНулевойШириной(ТаблицаРезультат);
	
	Возврат ТаблицаРезультат;
	
КонецФункции

&НаСервере
Процедура УдалитьКолонкиСНулевойШириной(ТаблицаРезультат)
	Перем МассивПустыхКолонок;
	
	// Найдем пустые колонки.
	МассивПустыхКолонок = Новый Массив;
	Для Каждого Колонка ИЗ ТаблицаРезультат.Колонки Цикл
		Если Колонка.Ширина = 0 Тогда
			МассивПустыхКолонок.Добавить(Колонка.Имя);
		КонецЕсли;
	КонецЦикла;
	
	// Удалим пустые колонки.
	Для Каждого ПустаяКолонка ИЗ МассивПустыхКолонок Цикл
		ТаблицаРезультат.Колонки.Удалить(ПустаяКолонка);
	КонецЦикла;
	
КонецПроцедуры

// ПРЕОБРАЗОВАНИЕ СТРОКИ К ТИПИЗОВАННОМУ ЗНАЧЕНИЮ 1С.

&НаСервере
Функция ПреобразоватьПростоеЗначениеИзСтрокиВТипизованноеЗначение1С(Знач ИсходноеЗначение)
	
	Если НЕ ИсходноеЗначение = "" Тогда
		Если ТолькоЦифрыИЗапятаяВСтроке(ИсходноеЗначение, Истина, Ложь) Тогда
			Попытка
				Возврат Число(ИсходноеЗначение);
			Исключение
				Возврат ИсходноеЗначение
			КонецПопытки;
		Иначе
			Если ВРег(ИсходноеЗначение) = "ИСТИНА" ИЛИ ВРег(ИсходноеЗначение) = ("ИСТИНА"+Символы.ПС) ИЛИ ВРег(ИсходноеЗначение) = "TRUE" ИЛИ ВРег(ИсходноеЗначение) = ("TRUE"+Символы.ПС) Тогда
				Возврат Истина;
			ИначеЕсли ВРег(ИсходноеЗначение) = "ЛОЖЬ" ИЛИ  ВРег(ИсходноеЗначение) = ("ЛОЖЬ"+Символы.ПС) ИЛИ ВРег(ИсходноеЗначение) = "FALSE" ИЛИ ВРег(ИсходноеЗначение) = ("FALSE"+Символы.ПС) Тогда
				Возврат Ложь;
			Иначе
				Возврат ПреобразоватьИзСтрокиВДату(ИсходноеЗначение);
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
	
	Возврат ИсходноеЗначение
	
КонецФункции

// Проверяет, содержит ли строка только цифры и запятую.
//
// Параметры:
//  СтрокаПроверки          - Строка - Строка для проверки
//  УчитыватьЛидирующиеНули - Булево - Флаг учета лидирующих нулей, если Истина, то ведущие нули пропускаются
//  УчитыватьПробелы        - Булево - Флаг учета пробелов, если Истина, то пробелы при проверке игнорируются
//
// Возвращаемое значение:
//   Булево - Истина - строка содержит только цифры или пустая, Ложь - строка содержит иные символы.
//
&НаСервере
Функция ТолькоЦифрыИЗапятаяВСтроке(Знач СтрокаПроверки, Знач УчитыватьЛидирующиеНули = Истина, Знач УчитыватьПробелы = Истина)
	
	Если ТипЗнч(СтрокаПроверки) <> Тип("Строка") Тогда
		Возврат Ложь;
	КонецЕсли;
	
	Если НЕ УчитыватьПробелы Тогда
		СтрокаПроверки = СтрЗаменить(СтрокаПроверки, " ", "");
	КонецЕсли;
	
	Если Сред(СтрокаПроверки, 1, 1) = "-" Тогда
		СтрокаПроверки = Сред(СтрокаПроверки, 2, СтрДлина(СтрокаПроверки));
	КонецЕсли;
	
	Если ПустаяСтрока(СтрокаПроверки) Тогда
		Возврат Истина;
	КонецЕсли;
	
	Если НЕ УчитыватьЛидирующиеНули Тогда
		Позиция = 1;
		// Взятие символа за границей строки возвращает пустую строку
		Пока Сред(СтрокаПроверки, Позиция, 1) = "0" Цикл
			Позиция = Позиция + 1;
		КонецЦикла;
		СтрокаПроверки = Сред(СтрокаПроверки, Позиция);
	КонецЕсли;
	
	// Если содержит только цифры, то в результате замен должна быть получена пустая строка
	// Проверять при помощи ПустаяСтрока нельзя, так как в исходной строке могут быть пробельные символы
	Возврат СтрДлина(
	СтрЗаменить( СтрЗаменить( СтрЗаменить( СтрЗаменить( СтрЗаменить(
	СтрЗаменить( СтрЗаменить( СтрЗаменить( СтрЗаменить( СтрЗаменить( СтрЗаменить( 
	СтрокаПроверки, "0", ""), "1", ""), "2", ""), "3", ""), "4", ""), "5", ""), "6", ""), "7", ""), "8", ""), "9", ""), ",", "")
	) = 0;
	
КонецФункции

// Преобразование строки вида "01.01.13" или "01.01.2013" к значению типа "дата".
// Возможны друние форматы даты в файле EXCEL.
&НаСервере
Функция ПреобразоватьИзСтрокиВДату(Знач СтрокаДаты)
	Перем ScrptCtrl, OutDate;
	
	Попытка
		ScrptCtrl = Новый COMОбъект("MSScriptControl.ScriptControl");
		ScrptCtrl.Language="vbscript";
		OutDate = ScrptCtrl.Eval("CDate(""" + СтрокаДаты + """)");
		Возврат OutDate;
	Исключение
		//Сообщить(ОписаниеОшибки());
	КонецПопытки;
	
	Возврат СтрокаДаты;
	
КонецФункции 

// ПОЛУЧЕНИЕ ЗНАЧЕНИЯ ДЛЯ РЕКВИЗИТА ТИПА "ФАЙЛ КАРТИНКИ".

&НаСервере
Функция ПолучитьЗначениеЯчейкиОбластиТабличногоДокументаСКартинками(Знач Область, Знач нСтрока, Знач нКолонка, Знач ПравилоИмяФайлаКартинки = "УИД")
	Перем Рисунок, ит, ИмяФайлаРисунка;
	Перем ЗначениеЯчейки;
	
	ит = 0;
	ЗначениеЯчейки = "";
	Для Каждого Рисунок ИЗ Область.Рисунки Цикл
		ит = ит + 1;
		Если ПравилоИмяФайлаКартинки = "УИД" Тогда
			ИмяФайлаРисунка = КаталогВременныхФайлов() + Новый УникальныйИдентификатор() + ".jpg";
		Иначе
			ИмяФайлаРисунка = КаталогВременныхФайлов() + "С" + нСтрока + "К" + нКолонка + ".jpg";
		КонецЕсли;
		Попытка
			Рисунок.Картинка.Записать(ИмяФайлаРисунка);
			ЗначениеЯчейки = ЗначениеЯчейки + ИмяФайлаРисунка + ?(ит < Область.Рисунки.Количество(), Символы.ПС, "");
		Исключение
			// Поле картинки недоступно для чтения.
		КонецПопытки;
	КонецЦикла;
	
	Возврат ЗначениеЯчейки;
	
КонецФункции

// ОБЩЕГО НАЗНАЧЕНИЯ.

&НаКлиентеНаСервереБезКонтекста
Функция ВерсияБезНомераСборки(Знач Версия)
	Перем Массив, Результат;
	
	Массив = РазложитьСтрокуВМассивПодстрок(Версия, ".");
	
	Если Массив.Количество() < 3 Тогда
		Возврат Версия;
	КонецЕсли;
	
	Результат = "[Редакция].[Подредакция].[Релиз]";
	Результат = СтрЗаменить(Результат, "[Редакция]",    Массив[0]);
	Результат = СтрЗаменить(Результат, "[Подредакция]", Массив[1]);
	Результат = СтрЗаменить(Результат, "[Релиз]",       Массив[2]);
	
	Возврат Результат;
КонецФункции

&НаСервере
Функция ВерсияПриложенияМеньше8310()
	Перем Версия;
	Версия = СтрЗаменить(ВерсияПриложенияБезНомераСборки, ".", "");
	Версия = Число(Версия);
	Возврат Версия <= 839;
КонецФункции

&НаКлиентеНаСервереБезКонтекста
Функция РазложитьСтрокуВМассивПодстрок(Знач Стр, Разделитель = ",")
	Перем МассивСтрок;
	
	МассивСтрок = Новый Массив();
	Если Разделитель = " " Тогда
		Стр = СокрЛП(Стр);
		Пока 1 = 1 Цикл
			Поз = Найти(Стр, Разделитель);
			Если Поз = 0 Тогда
				МассивСтрок.Добавить(СокрЛП(Стр));
				Возврат МассивСтрок;
			КонецЕсли;
			МассивСтрок.Добавить(СокрЛП(Лев(Стр, Поз - 1)));
			Стр = СокрЛ(Сред(Стр, Поз));
		КонецЦикла;
	Иначе
		ДлинаРазделителя = СтрДлина(Разделитель);
		Пока 1 = 1 Цикл
			Поз = Найти(Стр, Разделитель);
			Если Поз = 0 Тогда
				Если (СокрЛП(Стр) <> "") Тогда
					МассивСтрок.Добавить(СокрЛП(Стр));
				КонецЕсли;
				Возврат МассивСтрок;
			КонецЕсли;
			МассивСтрок.Добавить(СокрЛП(Лев(Стр,Поз - 1)));
			Стр = Сред(Стр, Поз + ДлинаРазделителя);
		КонецЦикла;
	КонецЕсли;
	
	Возврат МассивСтрок;
	
КонецФункции

ВерсияПриложенияБезНомераСборки = "";

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. StepByStep 3305 04.04.15 18:24 Сейчас в теме
УДАЧНОГО ПРИМЕНЕНИЯ ...
Kinestetik; shvo65; Gang031; AlexK_2012; mchammer4; jaroslav.h; veiuper; jobkostya1c8; 256mb; fvadim; +10 Ответить
2. jobkostya1c8 07.04.15 05:49 Сейчас в теме
Где-то про схожее уже писали, но чтоб не возиться нужно быстро найти шаблоны кода когда есть экстренная необходимость. Может, про картинки разве что. Попадаются задачи парсинга сайтов с использованием 1С.
3. StepByStep 3305 07.04.15 09:52 Сейчас в теме
(2) kostyaomsk,
Почерпнул из описании нововведений к платформе 8.3.6.
4. qwinter 614 07.04.15 15:01 Сейчас в теме
Зачем здесь все кроме
ТабличныйДокумент.Прочитать(ФайлEXCEL, СпособЧтенияЗначенийТабличногоДокумента.Значение);
?????

Скоро синтаксис-помощник будут публиковать...
eact; silberRus; +2 1 Ответить
5. StepByStep 3305 07.04.15 18:07 Сейчас в теме
(4) qwinter,

В данной публикации приводится пример реализации функционала импорта из файлов EXCEL (xlsx, xls, ods) в таблицу значений в режиме 1С:Предприятие на платформе 8.3.6.


Приведенный функционал вполне подходит для примера, о чем и написано выше в тексте публикации..
AlexK_2012; maxopik2; purgin; +3 Ответить
6. strangers 18.05.15 18:26 Сейчас в теме
Не считывает картинки из excel
7. StepByStep 3305 19.05.15 12:52 Сейчас в теме
(6) strangers,
Картинки должны находиться в пределах ячейки. В одной ячейке может быть несколько картинок.
В результирующую таблицу значений записываются ссылки на файлы картинок.
В ячейке, содержащей какртинки не должно быть ничего другого (текст, число и т.д.).
8. mostovaya 29.05.15 11:32 Сейчас в теме
Чем данный очередной загрузчик из эксель выделяется на фоне многих других?
9. StepByStep 3305 29.05.15 19:16 Сейчас в теме
(8) mostovaya,
Тем, что построен на возможностях новой платформы 8.3.6.
64. N191119 10.10.18 13:28 Сейчас в теме
(8) ему не требуется драйвера майкрософта или установленный офис на компьютере
10. rasswet 82 05.06.15 11:31 Сейчас в теме
а заполнять именованные области без использования ком объекта Эксель можно будет?
11. StepByStep 3305 08.06.15 13:46 Сейчас в теме
(10) rasswet,
Можно, если формировать ТабличныйДокумент, а не ТаблицуЗначений как здесь.
EXCEL не нужен.
12. tesseract 10.06.15 10:31 Сейчас в теме

КонечнаяКолонка = ТабличныйДокумент.ШиринаТаблицы; // 8.3.6.1760 некорректно определяет количество колонок (например, >=1025 для xlsx, =256 для xls).


Все читается корректно. Просто ТД может содержать строки с разным количеством колонок. Поэтому правильный вариант :

КоличествоКолонок = ТабличныйДокумент.ПолучитьОбласть(1,,1).ШиринаТаблицы;


Так мы получим реальное количество колонок в строке.
13. StepByStep 3305 10.06.15 20:14 Сейчас в теме
(12) tesseract,
СПАСИБО.
И в качестве развития мысли предлагаю:
КолВоКолонокФайла = ТабличныйДокумент.ПолучитьОбласть().ШиринаТаблицы;

В этом случае получим реальное количество колонок, вне зависимости от заполнения 1-ой строки.
(последние колонки, не имеющие заполненной 1-ой строки также будут учтены.)
Danil.Potapov; +1 Ответить
14. shydla 18.06.15 14:14 Сейчас в теме
Из xlsx картинки грузится, из xls - на доступно для чтения(
19. StepByStep 3305 16.08.15 15:32 Сейчас в теме
(14) shydla,
На платформе 8.3.6.2152 читает.
15. GVasiliy 21 08.07.15 14:31 Сейчас в теме
Нашел маленькую ошибку.
Переменная "СтрокаЗаголовка" не используется.
Для цикла считывающего наименования колонок следует исправить на:


НоваяСтрокаТФ[ИмяКолонки] = ТабличныйДокумент.ПолучитьОбласть("R" + Формат(СтрокаЗаголовка,"") + "C"+нКолонка).ТекущаяОбласть.Текст;
20. StepByStep 3305 16.08.15 15:33 Сейчас в теме
16. alekseineputin 13.07.15 14:41 Сейчас в теме
ТабличныйДокумент.Прочитать(ФайлEXCEL, СпособЧтенияЗначенийТабличногоДокумента.Значение);

А почему никто не пишет, что при использовании директивы"&НаСервере" в клиент-серверном варианте файл должен располагаться либо по сетевому пути, либо на сервере, где установлен "Агент сервера 1С:Предприятия 8.3 (x86-64)"?
hlopik; slayder; pavel_pss; irbis-auto; AGLux; NN2P; s03; dedicated; veiuper; RomaM; +10 Ответить
21. StepByStep 3305 16.08.15 15:34 Сейчас в теме
(16) mamanelli,
Да, так и есть. Это стандартно в клиент-серверном варианте.
25. kiv1c 541 02.09.15 17:35 Сейчас в теме
(16) mamanelli, то есть, в клиент-серверном варианте нет возможности прочитать файл с локального компьютера пользователя? и как быть?
26. TeMochkiN 04.09.15 10:21 Сейчас в теме
(25) kiv1c,
ТабличныйДокумент (SpreadsheetDocument)
Прочитать (Read)
Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
27. kiv1c 541 09.09.15 10:01 Сейчас в теме
(26) TeMochkiN, да, я разобрался, с клиента на сервер можно передать прочитанные из файла двоичные данные, потом на сервере их записать во временный эксель-файл и читать табличным документом из него.
17. urbanist 63 15.07.15 11:20 Сейчас в теме
Нужно ли для корректной работы этого функционала у "старых" конфигураций изменять режим совместимости?

А то не хочет работать в 8.3.6 (2076)

{Форма.Форма.Форма(26)}: Ошибка при вызове метода контекста (Прочитать)
ТабДок.Прочитать("D:\1.xls");
по причине:
Ошибка при выполнении файловой операции.

С любым параметром "СпособЧтенияЗначенийТабличногоДокумента" то же самое.



18. Samarin 96 16.07.15 14:19 Сейчас в теме
(17) urbanist, для использования данной возможности необходима платформа 8.3.6 с отключенным режимом совместимости.
Сейчас подобные вещи можно тестировать и смотреть на тестовых ЗУП 3.0.23 и БП 3.0.41, которые переводят на 8.3.6 со снятием режима совместимости (БСП версия 2.3).
22. StepByStep 3305 16.08.15 15:39 Сейчас в теме
(17) urbanist, (18) Samarin,
Режим совместимости не причем.
Не открыт ли файл в EXCEL?
Еще столкнулся с тем, что какая-то из версий LibreOffice коверкала файлы.
Поэтому рекомендую использовать MS EXCEL.
23. nytlenc 21.08.15 08:34 Сейчас в теме
В Функции
Функция ЗагрузитьМетодом_1C836(Знач ФайлEXCEL, Знач СтрокаЗаголовка = 1, НачСтрока = 0, КонСтрока = 0, КолвоСтрокФайла = 0)

замени строку:
Область = ТабличныйДокумент.ПолучитьОбласть("R"+нСтрока + "C"+нКолонка);

на:
Область = ТабличныйДокумент.ПолучитьОбласть("R"+Формат(нСтрока,"ЧГ=0") + "C"+Формат(нКолонка, "ЧГ=0"));

В противном случае когда итератор нСтрока или нКолонка достигнет значения 1000 будет подставляться как "1 000" соответственно
"R"+нСтрока + "C"+нКолонка
например будет равен значению "C1 000R1" или "C1R1 000" а такой области не существует. Будет ошибка в общем.
24. StepByStep 3305 01.09.15 12:55 Сейчас в теме
(23) nytlenc,
СПАСИБО. Правильно.
28. Morales 13.11.15 18:15 Сейчас в теме
Функция ТолькоЦифрыИЗапятаяВСтроке не отлавливает отрицательные числа
Надо добавить условие:
// Проверка на отрицательное число
Если Сред(СтрокаПроверки, 1, 1) = "-" Тогда
	СтрокаПроверки = Сред(СтрокаПроверки, 2, СтрДлина(СтрокаПроверки));
КонецЕсли; 
29. StepByStep 3305 15.11.15 18:36 Сейчас в теме
30. Lazerka 19.11.15 13:49 Сейчас в теме
Подскажите, а как загружать в 1с 8.3 из екселя формата xlsb это двоичные данные.
31. nofx 20.11.15 09:37 Сейчас в теме
(30) Lazerka, Также интересен этот вопрос.
32. StepByStep 3305 20.11.15 10:38 Сейчас в теме
(30) Lazerka, (31) nofx,
СПАСИБО.
Загрузка из XLSXB возможна черз ADODB.
Строка соединения = "Driver={Microsoft EXCEL Driver (*.xls, *.xlsx, *.xlsm, *.xlsb)};Dbq=" + ФайлEXCEL + ";ReadOnly=1;"
33. nofx 04.12.15 01:48 Сейчас в теме
34. ram8291 17.01.16 15:35 Сейчас в теме
Считываются все Листы Excel. Не понятно как считать только один Лист?
Наконец 1С родила долгожданный функционал!

35. StepByStep 3305 24.04.16 19:09 Сейчас в теме
(34) ram8291,
Из текста публикации:
О файле EXCEL:
В общем случае файл EXCEL содержит несколько листов с данными.
Метод табличного документа "Прочитать" читает все листы в 1 (один) табличный документ.
Поэтому в исходном файле EXCEL должен быть только один лист.
36. Гость 10.05.16 19:48
Проблема: числовые значения заполняются в Таблицу Значений правильно (как числа) из файла Эксель (через Табличный Документ), только если числа не содержат десятичной (дробной) части. Если есть дробная часть, то они записываются как текстовые значения, либо как тип Дата.

Пытался менять региональные настройки ("," или "." в качестве разделителей дробной части) и Региональные настройки базы данных 1С - безрезультатно.
37. StepByStep 3305 15.05.16 19:23 Сейчас в теме
(36) Гость,
Рекомендовал бы Вам обратить внимание на обработку Импорт из внешнего источника в 1С: infostart.ru
В ней механизм загрузки данным методом уточнен (несколько изменен функционал по типизации значений).
38. phil1n 20.07.16 14:46 Сейчас в теме
На платформе 8.3.6.2299 даты со временем в интервале 11:59:30 - 11:59:59 не считываются
39. StepByStep 3305 21.07.16 13:38 Сейчас в теме
(38) phil1n,
В том числе не берет и некоторые форматы даты (в общем-то "экзотические"), существующие в EXCEL.
40. borzyj 10.10.16 01:43 Сейчас в теме
Есть еще нюанс
при работе с файлами эксель формата офис 95 вызывается исключение, учтите это на коммерческих проектах
41. StepByStep 3305 30.10.16 17:41 Сейчас в теме
(40) borzyj,
Старый формат.
Можно пересохранить файл в более современном формате каким-либо офисом.
42. borzyj 20.11.16 04:11 Сейчас в теме
(41) StepByStep,
Была у меня задача, когда было необходимо загружать заказы от покупателей, приходящие в формате XL 95, база в клиент-серверном варианте, обработка на сервере, где офис не установлен, и никакого автоконвертера я не нашел, пришлось использовать другой способ обработки файла без установки мс Офис на сервер
43. Soikalv 16.12.16 12:37 Сейчас в теме
Очень интересная и полезная обработка. На 8.2. очень часто была нужна и нужна на 8.3. переход на 8.3 - вынужденный. Объясните, почвему ядолжна выкладывать 1200 рублей, если переход на 8.3. был вынужден? Меня все устраивало..
44. olegmedvedev 16.12.16 12:45 Сейчас в теме
(43) Вы о чем? это не обработка, это бесплатная статья, в которой рассказывается как можно загрузить из Экселя в 1С, приводится метод который автор предлагает воспользоваться.
Про переход с 8.2 на 8.3 тут ничего не говорится, денег автор тоже не требует за свою статью.
ilyaleontyev; +1 Ответить
45. logarifm 1065 09.05.17 12:06 Сейчас в теме
сделайте обработкой и залейте для скача. Спасибо!
47. StepByStep 3305 07.06.17 14:18 Сейчас в теме
(45)
Практическое применение:
"Импорт из EXCEL и других источников (xls, xlsx, xlsb, ods, sxc, dbf, mxl, csv, clipboard, sql) в 1С"
http://infostart.ru/public/120961/
46. lisrws 103 19.05.17 21:25 Сейчас в теме
с конструкцией для определения количества колонок "ОбластьФайла.ПолучитьРазмерОбластиДанныхПоГоризонтали()" будьте осторожны. она определяет количество колонок по первой строке. у меня в первой строке 6 колонок с данными, а с 7 строки уже 8 колонок. конструкция возвращает мне 6. если в первой строке добавить данные в 7 и 8 колонки, то вернет 8 как и должно быть. релиз "8.3.10.2252"
48. StepByStep 3305 07.06.17 14:21 Сейчас в теме
(46)
Совершенно верно, так и есть.
При загрузке предполагается, что исходная таблица должным образом оформлена, т.е. со всей заполненной 1-ой строкой.
49. aleksey.kubovtsov 77 19.09.17 22:18 Сейчас в теме
Спасибо за публикацию .

У меня была проблема, может кому поможет в решение:
Строку вида "01.02.2017" при чтение excel табличным документом воспринималась как 01.ММ.2017
помогло
ТабДокумент.Прочитать(ВременныйФайл,СпособЧтенияЗначенийТабличногоДокумента.Значение);
50. abrafaks 09.11.17 15:52 Сейчас в теме
Единственное, я бы вместо "Пока 1=1 Цикл" (так писали в 7.7), написал бы "Пока Истина Цикл".
51. ilp06 20.12.17 09:55 Сейчас в теме
Как считать 1-ый лист?
Опять в 1с всё через ..опу!
Нафига области сортировать! Порядок листов - от балды.
Жесть.
52. ilp06 20.12.17 10:15 Сейчас в теме
Есть решение:
Нужно сортировать по реквизиту Верх области.
Тогда порядок будет соответствовать порядку листов в Excel-файле.
user1073328; +1 Ответить
53. Daniayr 24.12.17 18:09 Сейчас в теме
Коллеги, подскажите как закрывать тот файл с которым работаешь (импорт), у меня закрыает все что открыто
использую LibreOffice
54. fedor40 687 22.01.18 10:16 Сейчас в теме
Вставил весь код в модуль внеш обработки. Работаю на 8.3.10.2580.
Выдает ошибку:{ВнешняяОбработка.ВнешняяОбработка1.МодульОбъекта(8,36)}: Процедура или функция с указанным именем не определена (ВерсияБезНомераСборки)
ВерсияПриложенияБезНомераСборки = <<?>>ВерсияБезНомераСборки(СистемнаяИнформация.ВерсияПриложения); (Проверка: Сервер).

Странно. Я так и не понял в чем ошибка.
55. vis_tmp 30 27.03.18 19:39 Сейчас в теме
Спасибо, очень полезная публикация!
56. It-developer 20 02.04.18 17:47 Сейчас в теме
Хороший шаблон для своего модуля работа с Эксель. Спасибо
57. Stradivari 147 12.04.18 14:41 Сейчас в теме
Спасибо. Статья выручила!
58. premierex 18.04.18 15:58 Сейчас в теме
(0) Статья отличная. Плюс, несомненно. Но вот от объекта MSScriptControl.ScriptControl я бы всё же отказался, потому как существует только 32-х битная реализация этой библиотеки и она просто не загрузится в 64-х битный серверный процесс. Выход, конечно, есть, но он уж очень похож на танец с бубнами.
59. KAV2 25.04.18 12:00 Сейчас в теме
Есть такой нюанс с использованием ТабличногоДокумента в тонком клиенте: если файл уже открыт в Excel, то не получается передать его на сервер для обработки с помощью метода ПоместитьФайлы - файл оказывается заблокированным другим приложением
60. premierex 29.04.18 09:31 Сейчас в теме
(0) Функционал чтения многостраничного документа можно значительно упростить. Вместо того, чтобы дважды читать документ для определения количества листов и их имен:
ОбластьФайла = ТабличныйДокумент.ПолучитьОбласть(ИмяЛиста);

можно использовать конструкцию:
ОбластьФайла = ТабличныйДокумент.Области[Мин(ИндексЛиста, ТабличныйДокумент.Области.Количество() - 1]);
vugluscr1991; KAV2; +2 Ответить
61. vis_tmp 30 04.05.18 15:34 Сейчас в теме
(0)Не могу понять, загружается ли гиперссылка из ячейки Excel-а?
Гиперссылка представляет из себя URL на картинку на сайте (прилагаю для примера кусочек такого файла).
В блоке:
Если ЗначениеЗаполнено(ЗначениеЯчейки) Тогда
	ЗначениеЯчейки = ПреобразоватьПростоеЗначениеИзСтрокиВТипизованноеЗначение1С(ЗначениеЯчейки);
	Если ТипЗнч(ЗначениеЯчейки) = Тип("Строка") Тогда
		ЗначениеЯчейки = СокрЛП(ЗначениеЯчейки);
	КонецЕсли;
Иначе
	ЗначениеЯчейки = Неопределено;
	Если Область.Рисунки.Количество() > 0 Тогда    // Изображение.
		ЗначениеЯчейки = ПолучитьЗначениеЯчейкиОбластиТабличногоДокументаСКартинками(Область, нСтрока, нКолонка, "УИД");
	КонецЕсли;
КонецЕсли;
Показать

переменная "ЗначениеЯчейки" содержит просто текст "Изображение"...
Кому-нибудь удалось получить URL гиперссылки из подобного файла?
Прикрепленные файлы:
PRICE - сантехника MIN.xls
62. Redhatych 35 05.09.18 14:13 Сейчас в теме
(61) как получить URL гиперссылки.
может быть кому-то пригодится.
предварительно в файле Excel создайте макрос, вытягивающий URL из таких ячеек. и с этим столбцом работайте
подробности здесь: http://mindubaev.com/internet-marketing/seo/kak-vytashhit-giperssylku-iz-excel/
63. vis_tmp 30 05.09.18 20:01 Сейчас в теме
65. OlaIa 20.02.19 09:23 Сейчас в теме
Добрый день.
А как быть с чтением файла Excel, который защищен паролем?
В этом случае ТабличныйДокумент.Прочитать не работает.
66. vis_tmp 30 20.02.19 12:59 Сейчас в теме
(65)Тут уже, скорее всего, ничего не поделаешь...
67. DMSDeveloper 129 06.03.19 11:15 Сейчас в теме
По мне так механизм чтения Excel средствами платформы еще очень сырой.
Вот вам живой пример

Есть файл, формата Excel-97 (xls) с формой УПД, которую нам по почте присылает поставщик.

Ячейка "Всего к оплате" имеет числовое значение 27 191,66
Метод прочитать, табличного документа, с типом чтения "Значение" получает 27 192! Зачем это платформа 1С сделала округление?
При выборе типа чтения "Текст" выдает еще более интересный вариант - "General27192"! Это вообще откуда?


Все на скринах.
Веселый файл тоже во вложении.
З.Ы. Редактировать и пересохранять файл не предлагать! Он грузится автоматом при получении почты.
Прикрепленные файлы:
19012903157.xls
69. kn 101 08.10.19 11:49 Сейчас в теме
Автору спасибо за пример работы с листами в 8.3.10
(67) xls можно скриптом преобразовывать
&НаСервере
Процедура ЗагрузитьИзФайла(АдресФайла, ВыбИмяФайла)
	
	Расш = ПолучитьРасширениеФайла(ВыбИмяФайла);
	
	Если Расш = "xls"  Тогда
		
		Попытка
	     лДвоичДанные = ПолучитьИзВременногоХранилища(АдресФайла);
	     лФайл = ПолучитьИмяВременногоФайла(Расш);
	     лДвоичДанные.Записать(лФайл);
		Исключение
			Сообщить(ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		Попытка
			Excel = Новый COMОбъект("Excel.Application");
			ОткрытаяКнига = Excel.WorkBooks.Open(лФайл);
			ИмяФайла = ПолучитьИмяВременногоФайла("xlsx");
			Excel.DisplayAlerts=0;
			ОткрытаяКнига.SaveAs(ИмяФайла, 51);
			Excel.DisplayAlerts = 1;
		Исключение
			Сообщить(ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
		Excel.DisplayAlerts = 0;
		Excel.WorkBooks.Close();
		Excel.DisplayAlerts = 1;
		Excel.Quit();
		Excel = Неопределено;
		
		ТабличныйДокумент.Очистить();
	    ТабличныйДокумент.Прочитать(ИмяФайла, СпособЧтенияЗначенийТабличногоДокумента.Значение);

	Иначе
		
	    Попытка
		 лФайл = ПолучитьИмяВременногоФайла(Расш);
	     лДвоичДанные = ПолучитьИзВременногоХранилища(АдресФайла);
	     лДвоичДанные.Записать(лФайл);
	    Исключение
			Сообщить(ОписаниеОшибки());
			Возврат;
		КонецПопытки;
		
	    ТабличныйДокумент.Очистить();
	    ТабличныйДокумент.Прочитать(лФайл, СпособЧтенияЗначенийТабличногоДокумента.Значение);
	
	КонецЕсли;
	
КонецПроцедуры
Показать
70. vis_tmp 30 08.10.19 16:42 Сейчас в теме
(69)Во что преобразуется?
Какой файл получится в результате?
71. kn 101 08.10.19 17:00 Сейчас в теме
(70)xls в xlsx, тот можно Прочитать(). Раньше xls не читался.
72. kn 101 08.10.19 17:10 Сейчас в теме
(67)да неправа, выдает тоже 27 192.
68. eact 08.04.19 14:50 Сейчас в теме
Странно преобразует числа... Например "16,9" преобразует в "16,899999999999999"...
Или "35,09" в "35,090000000000003"

Хотя в изначально в ексель четко число 35,09 и 16,9
73. kos-1cpp 19.12.19 14:45 Сейчас в теме
при чтении первого листа (без учета версий 1с8), предлагаю простую мини-функцию 8))

Функция ПолучитьТЗизФайлаЕксель(ИмяФайлаЗагрузки,знач НачСтрока=1,знач НачКолонка=1,знач КонСтрока=0,знач КонКолонка=0)
	
	ТЗ =  Новый ТаблицаЗначений;
	
	ТабДок = Новый ТабличныйДокумент;
	ТабДок.Прочитать(ИмяФайлаЗагрузки,СпособЧтенияЗначенийТабличногоДокумента.Значение);
	
	Область = ТабДок.ПолучитьОбласть();
	КоличествоСтрок	  = Область.ВысотаТаблицы;
	КоличествоКолонок = Область.ШиринаТаблицы;
	
	КоличествоСтрок = ?(КонСтрока=0,КоличествоСтрок,Мин(КоличествоСтрок,КонСтрока));
	КоличествоКолонок = ?(КонКолонка=0,КоличествоКолонок,Мин(КоличествоКолонок,КонКолонка));
		
	Для нКолонка = НачКолонка По КоличествоКолонок Цикл
		ТЗ.Колонки.Добавить("Колонка" + СокрЛП(нКолонка));
	КонецЦикла;
	
	Для нСтрока = НачСтрока По КоличествоСтрок Цикл
		НоваяСтрока = ТЗ.Добавить();
		Для нКолонка = НачКолонка По КоличествоКолонок Цикл
			Область = ТабДок.Область(нСтрока,нКолонка,нСтрока,нКолонка);
			Если Область.СодержитЗначение Тогда
				НоваяСтрока.Установить(нКолонка-1,Область.Значение);
			Иначе
				НоваяСтрока.Установить(нКолонка-1,СокрЛП(Область.Текст));
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
	
	Возврат ТЗ;
КонецФункции
Показать
Оставьте свое сообщение

См. также

[СКД] Программное создание схемы компоновки данных

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    4488    John_d    18       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.12.х и УТ 11.4.11.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Агрегатные функции СКД, о которых мало кто знает

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    21015    ids79    45       

Три костыля. Сказ про фокусы в коде

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    13059    YPermitin    70       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Отслеживание выполнения фонового задания

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    16381    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    26979    ids79    34       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Фоновое выполнение кода в 1С - это просто

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    16486    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    22857    ids79    8       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    17348    ids79    27       

Регистры сведений. За кулисами

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    13462    YPermitin    12       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

"Меньше копипаста!", или как Вася универсальную процедуру писал

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    11518    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    28944    ids79    17       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    15898    dmurk    144       

Регистры накопления. Структура хранения в базе данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    25044    YPermitin    27       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Выполнение внешней обработки в фоновом задании

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    15953    Eret1k    23       

Выгрузка документа по условию

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    8841    m-rv    2       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Преобразование EXCEL в таблицу значений без COM и других извращений

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Получение таблицы значений из excel в 1С v8, без COM, внешних источников данных и т.д. EXCELВТаблицуЗначений() - За 10 строчек кода! Реализация протестирована на 1С 8.3.12.1714 (x64).

18.04.2019    16875    9    Eret1k    43       

Как прикрутить ГУИД к регистру сведений

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    11836    m-rv    16       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

О расширениях замолвите слово...

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    21616    ellavs    125       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    17498    ellavs    83       

Трюки с внешними источниками данных

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    19100    YPermitin    53       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    22599    ids79    9       

Копирование числовых ячеек из 1С в Excel

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    14713    itriot11    21